Apache Maven 1.x has reached its end of life, and is no longer supported. For more information, see the announcement. Users are encouraged to migrate to the current version of Apache Maven.

Deprecation Warning

This plugin has been removed from the current Maven distribution, it is not maintained by the Maven team anymore. Please check the Plugins History page to find out the last Maven version that included this plugin.

Maven Jetty plugin

This plugin starts Jetty on the J2EE modules specified as dependencies.

Using the plugin

Define the WARs to deploy in Jetty as project dependencies. For example:


Note: If you run the jetty:run-war goal, your current project will also be considered as a WAR and it will be also deployed in Jetty.