Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 41
Number of unique artifacts (NOA): 53
Number of version-conflicting artifacts (NOC): 5
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 77 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in this project

junit:junit

[Error]
3.8.1
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:2.1:test
       \- org.codehaus.plexus:plexus-archiver:jar:2.2:test
          \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:test
             \- (junit:junit:jar:3.8.1:test - omitted for conflict with 4.12)

4.12
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- junit:junit:jar:4.12:test

org.apache.maven.shared:maven-shared-utils

[Error]
0.1
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven.shared:maven-shared-incremental:jar:1.1:compile
       \- (org.apache.maven.shared:maven-shared-utils:jar:0.1:compile - omitted for conflict with 3.1.0)

3.1.0
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven.shared:maven-shared-utils:jar:3.1.0:compile

org.apache.maven:maven-core

[Error]
2.2.1
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven.shared:maven-shared-incremental:jar:1.1:compile
       \- (org.apache.maven:maven-core:jar:2.2.1:compile - omitted for conflict with 3.0)

3.0
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    +- org.apache.maven:maven-core:jar:3.0:compile
    \- org.apache.maven:maven-compat:jar:3.0:test
       \- (org.apache.maven:maven-core:jar:3.0:test - omitted for duplicate)

org.apache.maven:maven-plugin-api

[Error]
2.2.1
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven.shared:maven-shared-incremental:jar:1.1:compile
       \- (org.apache.maven:maven-plugin-api:jar:2.2.1:compile - omitted for conflict with 3.0)

3.0
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    +- org.apache.maven:maven-plugin-api:jar:3.0:compile
    \- org.apache.maven:maven-core:jar:3.0:compile
       \- (org.apache.maven:maven-plugin-api:jar:3.0:compile - omitted for duplicate)

org.codehaus.plexus:plexus-utils

[Error]
1.0.4
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:2.1:test
       \- org.codehaus.plexus:plexus-archiver:jar:2.2:test
          \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:test
             \- (org.codehaus.plexus:plexus-utils:jar:1.0.4:test - omitted for conflict with 2.0.4)

1.4.2
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven:maven-compat:jar:3.0:test
       \- org.apache.maven.wagon:wagon-provider-api:jar:1.0-beta-6:test
          \- (org.codehaus.plexus:plexus-utils:jar:1.4.2:test - omitted for conflict with 2.0.4)

1.5.5
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven:maven-core:jar:3.0:compile
       \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:compile
          \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:compile - omitted for conflict with 2.0.4)

2.0.4
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    +- org.apache.maven:maven-plugin-api:jar:3.0:compile
    |  \- org.apache.maven:maven-model:jar:3.0:compile
    |     \- (org.codehaus.plexus:plexus-utils:jar:2.0.4:compile - omitted for duplicate)
    +- org.apache.maven:maven-artifact:jar:3.0:compile
    |  \- org.codehaus.plexus:plexus-utils:jar:2.0.4:compile
    +- org.apache.maven:maven-core:jar:3.0:compile
    |  +- org.apache.maven:maven-settings:jar:3.0:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:2.0.4:compile - omitted for duplicate)
    |  +- org.apache.maven:maven-settings-builder:jar:3.0:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:2.0.4:compile - omitted for duplicate)
    |  +- org.apache.maven:maven-repository-metadata:jar:3.0:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:2.0.4:compile - omitted for duplicate)
    |  +- org.apache.maven:maven-model-builder:jar:3.0:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:2.0.4:compile - omitted for duplicate)
    |  \- (org.codehaus.plexus:plexus-utils:jar:2.0.4:compile - omitted for duplicate)
    \- org.apache.maven:maven-compat:jar:3.0:test
       \- (org.codehaus.plexus:plexus-utils:jar:2.0.4:test - omitted for duplicate)

2.0.5
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven:maven-plugin-api:jar:3.0:compile
       \- org.sonatype.sisu:sisu-inject-plexus:jar:1.4.2:compile
          \- (org.codehaus.plexus:plexus-utils:jar:2.0.5:compile - omitted for conflict with 2.0.4)

3.0
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:2.1:test
       \- org.codehaus.plexus:plexus-archiver:jar:2.2:test
          \- org.codehaus.plexus:plexus-io:jar:2.0.4:test
             \- (org.codehaus.plexus:plexus-utils:jar:3.0:test - omitted for conflict with 2.0.4)

3.0.22
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    +- org.codehaus.plexus:plexus-compiler-api:jar:2.8.1:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:compile - omitted for conflict with 2.0.4)
    \- org.codehaus.plexus:plexus-compiler-javac:jar:2.8.1:runtime
       \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:runtime - omitted for conflict with 2.0.4)

3.0.7
    org.apache.maven.plugins:maven-compiler-plugin:maven-plugin:3.6.0
    \- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:2.1:test
       \- org.codehaus.plexus:plexus-archiver:jar:2.2:test
          \- (org.codehaus.plexus:plexus-utils:jar:3.0.7:test - omitted for conflict with 2.0.4)