Plugin Documentation

Goals available for this plugin:

Goal Description
eclipse:add-maven-repo Deprecated. Use configure-workspace goal instead.
eclipse:clean Deletes the .project, .classpath, .wtpmodules files and .settings folder used by Eclipse.
eclipse:configure-workspace Configures The following Eclipse Workspace features:
  • Adds the classpath variable MAVEN_REPO to Eclipse.
  • Optionally load Eclipse code style file via a URL.
eclipse:eclipse Generates the following eclipse configuration files:
  • .project and .classpath files
  • .setting/org.eclipse.jdt.core.prefs with project specific compiler settings
  • various configuration files for WTP (Web Tools Project), if the parameter wtpversion is set to a valid version (WTP configuration is not generated by default)
If this goal is run on a multiproject root, dependencies between modules will be configured as direct project dependencies in Eclipse (unless useProjectReferences is set to false).
eclipse:help Display help information on maven-eclipse-plugin.
  mvn eclipse:help -Ddetail=true -Dgoal=<goal-name>
to display parameter details.
eclipse:install-plugins Install plugins resolved from the Maven repository system into an Eclipse instance.
eclipse:make-artifacts Deprecated. use EclipseToMavenMojo for the latest naming conventions
eclipse:myeclipse Generates MyEclipse configuration files
eclipse:myeclipse-clean Deletes configuration files used by MyEclipse
eclipse:rad Generates the rad-6 configuration files.
eclipse:rad-clean Deletes the config files used by Rad-6. the files .j2ee and the file .websettings
eclipse:remove-cache Removes the not-available marker files from the repository.
eclipse:to-maven Add eclipse artifacts from an eclipse installation to the local repo. This mojo automatically analize the eclipse directory, copy plugins jars to the local maven repo, and generates appropriate poms. This is the official central repository builder for Eclipse plugins, so it has the necessary default values. For customized repositories see MakeArtifactsMojo Typical usage: mvn eclipse:to-maven -DeclipseDir=.

System Requirements

The following specifies the minimum requirements to run this Maven plugin:

Maven 2.0.1
JDK 1.4
Memory No minimum requirement.
Disk Space No minimum requirement.


You should specify the version in your project's plugin configuration:

    <!-- To define the plugin version in your parent POM -->
    <!-- To use the plugin goals in your POM or parent POM -->

For more information, see "Guide to Configuring Plug-ins"