Plugin Documentation

Goals available for this plugin:

eclipse:add-maven-repoDeprecated. Use configure-workspace goal instead.
eclipse:cleanDeletes the .project, .classpath, .wtpmodules files and .settings folder used by Eclipse.
eclipse:configure-workspaceConfigures The following Eclipse Workspace features:
  • Adds the classpath variable MAVEN_REPO to Eclipse.
  • Optionally load Eclipse code style file via a URL.
eclipse:eclipseGenerates the following eclipse configuration files:
  • .project and .classpath files
  • .setting/org.eclipse.jdt.core.prefs with project specific compiler settings
  • various configuration files for WTP (Web Tools Project), if the parameter wtpversion is set to a valid version (WTP configuration is not generated by default)
If this goal is run on a multiproject root, dependencies between modules will be configured as direct project dependencies in Eclipse (unless useProjectReferences is set to false).
eclipse:helpDisplay help information on maven-eclipse-plugin.
  mvn eclipse:help -Ddetail=true -Dgoal=<goal-name>
to display parameter details.
eclipse:install-pluginsInstall plugins resolved from the Maven repository system into an Eclipse instance.
eclipse:make-artifactsDeprecated. use EclipseToMavenMojo for the latest naming conventions
eclipse:myeclipseGenerates MyEclipse configuration files
eclipse:myeclipse-cleanDeletes configuration files used by MyEclipse
eclipse:radGenerates the rad-6 configuration files.
eclipse:rad-cleanDeletes the config files used by Rad-6. the files .j2ee and the file .websettings
eclipse:remove-cacheRemoves the not-available marker files from the repository.
eclipse:to-mavenAdd eclipse artifacts from an eclipse installation to the local repo. This mojo automatically analize the eclipse directory, copy plugins jars to the local maven repo, and generates appropriate poms. This is the official central repository builder for Eclipse plugins, so it has the necessary default values. For customized repositories see MakeArtifactsMojo Typical usage: mvn eclipse:to-maven -DeclipseDir=.

System Requirements

The following specifies the minimum requirements to run this Maven plugin:

MemoryNo minimum requirement.
Disk SpaceNo minimum requirement.


You should specify the version in your project's plugin configuration:

    <!-- To define the plugin version in your parent POM -->
    <!-- To use the plugin goals in your POM or parent POM -->

For more information, see "Guide to Configuring Plug-ins"