Plugin Documentation

Goals available for this plugin:

GoalReport?Description
pmd:checkNoFail the build if there were any PMD violations in the source code.
pmd:cpdYesCreates a report for PMD's CPD tool. See http://pmd.sourceforge.net/cpd.html for more detail.
pmd:cpd-checkNoFail the build if there were any CPD violations in the source code.
pmd:helpNoDisplay help information on maven-pmd-plugin.
Call mvn pmd:help -Ddetail=true -Dgoal=<goal-name> to display parameter details.
pmd:pmdYesCreates a PMD report.

System Requirements

The following specifies the minimum requirements to run this Maven plugin:

Maven2.2.1
JDK1.5
MemoryNo minimum requirement.
Disk SpaceNo minimum requirement.

Usage

You should specify the version in your project's plugin configuration:

<project>
  ...
  <build>
    <!-- To define the plugin version in your parent POM -->
    <pluginManagement>
      <plugins>
        <plugin>
          <groupId>org.apache.maven.plugins</groupId>
          <artifactId>maven-pmd-plugin</artifactId>
          <version>3.0</version>
        </plugin>
        ...
      </plugins>
    </pluginManagement>
    <!-- To use the plugin goals in your POM or parent POM -->
    <plugins>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-pmd-plugin</artifactId>
        <version>3.0</version>
      </plugin>
      ...
    </plugins>
  </build>
  ...
  <!-- To use the report goals in your POM or parent POM -->
  <reporting>
    <plugins>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-pmd-plugin</artifactId>
        <version>3.0</version>
      </plugin>
      ...
    </plugins>
  </reporting>
  ...
</project>

For more information, see "Guide to Configuring Plug-ins"