Uses of Class

Packages that use InvalidVersionSpecificationException

Uses of InvalidVersionSpecificationException in org.apache.maven.artifact.versioning

Methods in org.apache.maven.artifact.versioning that throw InvalidVersionSpecificationException
static VersionRange VersionRange.createFromVersionSpec(String spec)
          Create a version range from a string representation

Some spec examples are 1.0 Version 1.0 [1.0,2.0) Versions 1.0 (included) to 2.0 (not included) [1.0,2.0] Versions 1.0 to 2.0 (both included) [1.5,) Versions 1.5 and higher (,1.0],[1.2,) Versions up to 1.0 (included) and 1.2 or higher


Copyright © 2001-2012 The Apache Software Foundation. All Rights Reserved.